Solucionar Problema Alsa en Ubuntu Lucid (Para Presario CQ42 y otras…)

Publicado: 15/07/2011 en Problemas Varios, Ubuntu
Etiquetas:, , , , ,

He conseguido una laptop Compaq Presario CQ42 para mi uso personal y pues despues de varios procesos me quede con Ubuntu Lucid Lynx 10.04 . La instalacion corrio bien y actualizacion. Pero me doy cuenta que no tengo audio para nada.

Asi, que me puse a investigar y encontre que el problema reside en ALSA(Advanced Linux Sound Architecture). Lucid trae predeterminado Alsa 1.0.21 pero nosotros necesitamos actualizar a 1.0.23 para tener audio correctamente.

Entonces les digo como arreglar el problemita:

Antes que nada, asegurate que has corrido todas las actualizaciones para tu sistema; sino hazlo primero antes de seguir este tutorial.Puede que lo resuelvas asi nada más.

Esto esta documentado por los usuarios para las siguientes computadoras:
Compaq Presario CQ42-205LA
Vaio VPCEB17FL
Sony VAIO VPCY115FX
Gateway  MT6821
Asus ITX Mobo with NVidia ION
Siemens Amilo Li 1705
Acer Apire 4740
Vaio VPCEB1M1E

Entre otras…

1. Determinamos la version que tenemos de ALSA desde la terminal:

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.21.

2. Para evitar problemas con la actualizacion de Alsa-utils pararemos los servicios :

sudo /sbin/alsa-utils stop

Si tienen problemas en este punto prueban con:

sudo /lib/udev/alsa-utils stop

Si continua el problema ignoren este paso y sigan (la instalacion deberia pararselos)

3. Ahora necesitamos descargar las herramientas necesarias para compilar nuestro kernel:

sudo apt-get -y install build-essential ncurses-dev gettext xmlto libasound2-dev
sudo apt-get -y install linux-headers-`uname -r` libncursesw5-dev

Si estas seguro de tener estas herramientas en tu sistema, salta este paso .

4.Nos vamos a nuestro folder personal y bajamos alsa-driver, alsa-lib and alsa-utils :

  cd ~
rm -rf ~/alsa* ~/.pulse*
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.23.tar.bz2
wget ftp://ftp.alsa-project.org/pub/lib/alsa-lib-1.0.23.tar.bz2
wget ftp://ftp.alsa-project.org/pub/utils/alsa-utils-1.0.23.tar.bz2

5. Luego creamos un folder para colocar y compilar los archivos descargados , los movemos :

  sudo rm -rf /usr/src/alsa
sudo mkdir -p /usr/src/alsa
cd /usr/src/alsa
sudo cp ~/alsa* .

6. Descomprimimos :

  sudo tar xjf alsa-driver*
sudo tar xjf alsa-lib*
sudo tar xjf alsa-utils*

O, graficamente los descomprimes y los mueves como mas gustes.

7. Compilamos e instalamos el alsa-driver:

cd alsa-driver*
sudo ./configure
sudo make
sudo make install

8. Compilamos e instalamos alsa-lib:

cd ../alsa-lib*
sudo ./configure
sudo make
sudo make install

9. Compilamos e instalamos alsa-utils:

cd ../alsa-utils*
sudo ./configure
sudo make
sudo make install

10. Puedes borrar los 3 archivos tar de nuestro folder personal ya que no son necesarios:

rm -f ~/alsa-driver*
rm -f ~/alsa-lib*
rm -f ~/alsa-utils*

11. Ahora solo reinicia el sistema y al entrar procedes a verificar tu version (lo importante es la versión):

  cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.
Compiled on May 2 2010 for kernel 2.6.32-21-generic (SMP).

12. Ahora para verificar que todo este bien configurado ejecuta :

  sudo alsaconf

Veras algunas ventanas como las siguientes:

En esta segunda pantalla, deberias ver las tarjetas detectadas y escoges la tuya.Al finalizar aqui, reiniciamos nuevamente y
pruebas tu sonido.

Si al finalizar todos estos pasos todavia tienen problemas, deberas seguir los siguientes pasos y seguramente arreglas de una vez el problema.

13._Ingresamos a Synaptics; Configuracion>Repositorios>Otro Software y luego Añadir.Agregamos el siguiente repositorio:
ppa:ubuntu-audio-dev/ppa

ó

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa  (en la terminal)

14._Recargamos cuando nos pregunte hacerlo.

15._Desde Synaptic instalamos el paquete linux-backports-modules-alsa correspondiente a nuestro kernel.
Ej. Yo instale:
linux-backports-modules-alsa-2.6.32-32-generic (correspondiente a mi kernel)

16.-Reiniciamos el sistema.

17.-Verificamos nuestra version (paso 1) y asegurarte de tener la version 1.0.23

Espero les sirva este tutorial para este problemilla.Sino les funciona miren la fuente eso sí, ingles y leen los comentarios talves encuentran algo mas.Igual, si tienen preguntas lo hacen en comentarios la comunidad seguro nos ayuda.

Fuente Aqui

 

Share

Anuncios
comentarios
  1. […] | Vítor Suárez . Solución a los problemas de alsa/pulseaudio con las tarjetas intel … . Solucionar Problema Alsa en Ubuntu Lucid (Para Presario CQ42 y … var […]

    Me gusta

Dejanos tu comentario! Gracias!

Por favor, inicia sesión con uno de estos métodos para publicar tu comentario:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s